• TecomC4 drivers now available

TecomC4 drivers now available

DSC PowerSeries Neo Supported Versions:

    • Panel firmware 1.1 or 1.2 (HS2128 / HS2064 / HS2032 / HS2016)
    • IP module firmware 4.1 or 5.0 (TL280 / TL2803G)
Click here to download the Market Release Notice